Subaru Forum & Free Classified Buy & Sell Ads

An Unofficial Subaru Research Community
It is currently Fri Nov 24, 2017 6:52 pm

All times are UTC - 8 hours [ DST ]




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Sat May 12, 2012 4:25 pm 
Offline

Joined: Thu Jan 26, 2012 3:50 pm
Posts: 2
my 2002 outback sport has been bogging down and losing power before catching again, causing some close calls when merging and sending me 50 mph in town without warning once it gets back up to speed. when this is going on it usually starts shaking and the engine will start revving. and occasionally leads to stalls. i had my check engine light on, which said my knock sensor was bad, i replaced it and now the lights off but the problem hasn't stopped, anyone know what might be wrong?

i put a new fuel filter on it today, its still too early to say but it feels a little better but it's still a little sluggish when i first accelerate from a stop (especially when turning?) but its not unusual for it to run fine for a day or two and start acting up again out of nowhere


Top
 Profile  
 
PostPosted: Wed May 16, 2012 6:12 am 
Offline

Joined: Thu Jan 26, 2012 3:50 pm
Posts: 2
still haven't had any luck, ive decided to replace the front 02 sensor later today, and im thinking of replacing the catalytic converter, it has some rust damage and i recently replaced the muffler and res pipe, figured i might as well double tap it, ill keep progress posted but id appreciate any input


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group