Subaru Forum & Free Classified Buy & Sell Ads

An Unofficial Subaru Research Community
It is currently Tue Apr 25, 2017 11:01 pm

All times are UTC - 8 hours [ DST ]




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Sat May 05, 2012 8:37 am 
Offline

Joined: Sun Apr 22, 2012 8:40 am
Posts: 1
I have a Subaru Outback 3.0 2001. I just got it a few weeks ago. It keeps stalling out on me. I just had new plugs installed .while on the road crusing it also cuts in and out.I tried using high octane and regular , makes no difference.Any suggestions before i put more money out.It just passed inspection this morning. What could be causeing this.?


Top
 Profile  
 
PostPosted: Mon Jun 11, 2012 3:32 pm 
Offline

Joined: Thu May 08, 2008 10:26 am
Posts: 1
I had that problem with my 2000 legacy. It happened to me twice. The first time it was the O2 sensor, and the second time it was my battery fried. Hopes this helps.


Top
 Profile  
 
PostPosted: Wed Oct 24, 2012 10:17 pm 
Offline

Joined: Wed Oct 24, 2012 1:18 am
Posts: 1
Location: Washington
I had some problem with my subaru, and this problem solved by friends so i have no idea about it.

_________________
cars on auctions


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group